Home > HowTo, Linux > X-lite in ubuntu

X-lite in ubuntu

March 26th, 2009 Leave a comment Go to comments

Running x-lite in Ubuntu 8.10 hardy.

X-Lite is a VOiP application made by    http://www.counterpath.com/
it allows configuration via SIP protocol.

Download the application and then
# tar -zxvf X-Lite_Install.tar.gz
# cd xten-xlite
# chmod +x xtensoftphone
#./xtensoftphone

It will give an error:

./xtensoftphone: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

It requires the libstdc++.so.5 so install it via apt:
# apt-get install libstdc++5
# apt-get install alsa-oss

ref.
http://www.sipindex.com/
http://awcalien8.blogspot.com/

  1. Sounds
    October 30th, 2009 at 23:37 | #1

    It worked with Ubuntu 9.04 but it doesn’t with 9.10 🙁

    root@leaveme-alone:/home/sounds/xten-xlite# apt-get install libstdc++5
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Package libstdc++5 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package libstdc++5 has no installation candidate
    root@leaveme-alone:/home/sounds/xten-xlite#

  2. Fineguy
    November 19th, 2009 at 17:16 | #2

    Koala uses libstdc++6, which is installed by default, and not libstdc++5

  3. amila silva
    February 4th, 2010 at 02:33 | #3

    @Fineguy
    download the required library from
    Exactly from here:

    http://ftp.us.debian.org/debian/pool/main/g/gcc-3.3/libstdc++5_3.3.6-18_i386.deb

    and try out the x-lite
    enjoy x-lite

  4. Talat
    March 10th, 2010 at 02:27 | #4

    Dear Amila Silva, thank you very much, your link helped me to launch X-lite on Ubuntu 9.10,
    Now I started to tool up Asterisk 😉

  5. Jaydeep
    July 22nd, 2010 at 23:09 | #5

    Hi Amila Silva,

    I could install the library from http://ftp.us.debian.org/debian/pool/main/g/gcc-3.3/libstdc++5_3.3.6-18_i386.deb, and before that I had downloaded the tar.gz file from http://www.counterpath.com. I am not sure what steps I need to do to be able to use X-Lite on my Ubuntu 10.04 LTS. I am a true novice!

    Thanks.

    Jaydeep

  6. October 22nd, 2010 at 20:49 | #6

    Hi Amila Silva,

    I´ve just downloaded xtensoftphone for ubuntu 10.04(Lucid), and have configured it? SIP account and even I can make calls but the drill is I cant hear any sound of the party whom I´am calling not even the dialling tone,and same is the case with the receiver too.Please guide me with this problem,n thanx in advance.

  7. Dhanasekran
    November 23rd, 2010 at 08:09 | #7

    plz help me…

    debian:/home/dhana013/xten-xlite# ./xtensoftphone
    I/O warning : failed to load external entity “/root/.Xscrc”
    ^C
    debian:/home/dhana013/xten-xlite#

  1. No trackbacks yet.

VAMOVE *

*